const regex = new RegExp('(?s).*?(?:(?=([DKE])((?!\\1)[DKE])([DKE])([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?))(\\9\\8\\7\\6\\5\\4\\3\\2\\1|\\7\\6\\5\\4\\3\\2\\1|\\5\\4\\3\\2\\1|\\3\\2\\1))', 'gm')
const str = `KEKEKEKD
abaabadfkfdDKEKDDEDDD
KEK
DKEKD
DED
DKEKDKEKD
`;
const subst = `$10\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);