use strict;
my $str = 'KEKEKEKD
abaabadfkfdDKEKDDEDDD
KEK
DKEKD
DED
DKEKDKEKD
';
my $regex = qr/(?s).*?(?:(?=([DKE])((?!\1)[DKE])([DKE])([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?))(\9\8\7\6\5\4\3\2\1|\7\6\5\4\3\2\1|\5\4\3\2\1|\3\2\1))/mp;
my $subst = '$10\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";