import re
regex = re.compile(r"(?s).*?(?:(?=([DKE])((?!\1)[DKE])([DKE])([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?))(\9\8\7\6\5\4\3\2\1|\7\6\5\4\3\2\1|\5\4\3\2\1|\3\2\1))", flags=re.MULTILINE)
test_str = ("KEKEKEKD\n"
"abaabadfkfdDKEKDDEDDD\n"
"KEK\n"
"DKEKD\n"
"DED\n"
"DKEKDKEKD\n\n")
subst = "$10\\n"
result = regex.sub(subst, test_str)
if result:
print(result)