import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s).*?(?:(?=([DKE])((?!\\1)[DKE])([DKE])([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?)([DKE]?))(\\9\\8\\7\\6\\5\\4\\3\\2\\1|\\7\\6\\5\\4\\3\\2\\1|\\5\\4\\3\\2\\1|\\3\\2\\1))";
final String string = "KEKEKEKD\n"
+ "abaabadfkfdDKEKDDEDDD\n"
+ "KEK\n"
+ "DKEKD\n"
+ "DED\n"
+ "DKEKDKEKD\n\n";
final String subst = "$10\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}