#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bp(?!ęknięty\b|ęknięcie\b)"
Local $sString = "I have a string: prawy p pęknięty p zderzak pęknięcie (it's Polish language)" & @CRLF & _
"" & @CRLF & _
"I want to select all p (except "p" in words "pęknięty" and "peknięcie")" & @CRLF & _
"" & @CRLF & _
"I've tried to do something like that: \b(s*ps*)\b, but it doesn't work properly. Any ideas?" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")