import re
regex = re.compile(r"\bp(?!ęknięty\b|ęknięcie\b)", flags=re.MULTILINE)
test_str = ("I have a string: prawy p pęknięty p zderzak pęknięcie (it's Polish language)\n\n"
"I want to select all p (except \"p\" in words \"pęknięty\" and \"peknięcie\")\n\n"
"I've tried to do something like that: \\b(s*ps*)\\b, but it doesn't work properly. Any ideas?\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")