const regex = /\bp(?!ęknięty\b|ęknięcie\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bp(?!ęknięty\\b|ęknięcie\\b)', 'gm')
const str = `I have a string: prawy p pęknięty p zderzak pęknięcie (it's Polish language)
I want to select all p (except "p" in words "pęknięty" and "peknięcie")
I've tried to do something like that: \\b(s*ps*)\\b, but it doesn't work properly. Any ideas?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}