re = /\bp(?!ęknięty\b|ęknięcie\b)/m
str = 'I have a string: prawy p pęknięty p zderzak pęknięcie (it\'s Polish language)
I want to select all p (except "p" in words "pęknięty" and "peknięcie")
I\'ve tried to do something like that: \\b(s*ps*)\\b, but it doesn\'t work properly. Any ideas?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end