using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bp(?!ęknięty\b|ęknięcie\b)";
string input = @"I have a string: prawy p pęknięty p zderzak pęknięcie (it's Polish language)
I want to select all p (except ""p"" in words ""pęknięty"" and ""peknięcie"")
I've tried to do something like that: \b(s*ps*)\b, but it doesn't work properly. Any ideas?
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}