import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bp(?!ęknięty\\b|ęknięcie\\b)";
final String string = "I have a string: prawy p pęknięty p zderzak pęknięcie (it's Polish language)\n\n"
+ "I want to select all p (except \"p\" in words \"pęknięty\" and \"peknięcie\")\n\n"
+ "I've tried to do something like that: \\b(s*ps*)\\b, but it doesn't work properly. Any ideas?\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}