# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?: |^)(?!abc)[\w.-]*/\L\0/gmi;t' <<< "Baz Buzz ABCkjkJ.90_1 ABC-12_OLL Foo Bar"