const regex = /(?: |^)(?!abc)[\w.-]*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?: |^)(?!abc)[\\w.-]*', 'gmi')
const str = `Baz Buzz ABCkjkJ.90_1 ABC-12_OLL Foo Bar`;
const subst = `\L\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);