use strict;
my $str = 'Baz Buzz ABCkjkJ.90_1 ABC-12_OLL Foo Bar';
my $regex = qr/(?: |^)(?!abc)[\w.-]*/mip;
my $subst = '\\L\\0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";