#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?: |^)(?!abc)[\w.-]*"
Local $sString = "Baz Buzz ABCkjkJ.90_1 ABC-12_OLL Foo Bar"
Local $sSubst = "\L\0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)