using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?: |^)(?!abc)[\w.-]*";
string substitution = @"\L\0";
string input = @"Baz Buzz ABCkjkJ.90_1 ABC-12_OLL Foo Bar";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}