re = /(?: |^)(?!abc)[\w.-]*/mi
str = 'Baz Buzz ABCkjkJ.90_1 ABC-12_OLL Foo Bar'
subst = '\\L\\0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result