import Foundation
let pattern = #"(?: |^)(?!abc)[\w.-]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Baz Buzz ABCkjkJ.90_1 ABC-12_OLL Foo Bar"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L\0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)