$re = '/(?: |^)(?!abc)[\w.-]*/mi';
$str = 'Baz Buzz ABCkjkJ.90_1 ABC-12_OLL Foo Bar';
$subst = "\L\0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;