#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)([\w.-]*)(.+)"
Local $sString = "ABCkjkJ.90_1 xBC-12_OLL Foo Bar Baz Buzz"
Local $sSubst = "\1\L\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)