import Foundation
let pattern = #"([\w.-]*)(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"ABCkjkJ.90_1 xBC-12_OLL Foo Bar Baz Buzz"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\L\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)