package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([\w.-]*)(.+)`)
var str = `ABCkjkJ.90_1 xBC-12_OLL Foo Bar Baz Buzz`
var substitution = "\1\L\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}