using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w.-]*)(.+)";
string substitution = @"\1\L\2";
string input = @"ABCkjkJ.90_1 xBC-12_OLL Foo Bar Baz Buzz";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}