re = /([\w.-]*)(.+)/mi
str = 'ABCkjkJ.90_1 xBC-12_OLL Foo Bar Baz Buzz'
subst = '\\1\\L\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result