const regex = /([\w.-]*)(.+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w.-]*)(.+)', 'gmi')
const str = `ABCkjkJ.90_1 xBC-12_OLL Foo Bar Baz Buzz`;
const subst = `\1\L\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);