$re = '/([\w.-]*)(.+)/mi';
$str = 'ABCkjkJ.90_1 xBC-12_OLL Foo Bar Baz Buzz';
$subst = "\1\L\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;