use strict;
my $str = 'ABCkjkJ.90_1 xBC-12_OLL Foo Bar Baz Buzz';
my $regex = qr/([\w.-]*)(.+)/mip;
my $subst = '\\1\\L\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";