using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[Kk]en(?:ny2scratch)?|K2S)\b";
string input = @"Kenny2scratch - OK
kenny2scratch - OK
Ken - OK
ken - OK though not preferred
K2S - OK for shorthand
Kenny - DEFINITELY NOT OK
Kenny2Scratch - NOT OK because of the capital S
Kenny2 - NOT OK
k2s - NOT OK, at least capitalize it";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}