# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:[Kk]en(?:ny2scratch)?|K2S)\b"
test_str = ("Kenny2scratch - OK\n"
"kenny2scratch - OK\n"
"Ken - OK\n"
"ken - OK though not preferred\n"
"K2S - OK for shorthand\n"
"Kenny - DEFINITELY NOT OK\n"
"Kenny2Scratch - NOT OK because of the capital S\n"
"Kenny2 - NOT OK\n"
"k2s - NOT OK, at least capitalize it")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.