re = /\b(?:[Kk]en(?:ny2scratch)?|K2S)\b/
str = 'Kenny2scratch - OK
kenny2scratch - OK
Ken - OK
ken - OK though not preferred
K2S - OK for shorthand
Kenny - DEFINITELY NOT OK
Kenny2Scratch - NOT OK because of the capital S
Kenny2 - NOT OK
k2s - NOT OK, at least capitalize it'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end