use strict;
my $str = 'Kenny2scratch - OK
kenny2scratch - OK
Ken - OK
ken - OK though not preferred
K2S - OK for shorthand
Kenny - DEFINITELY NOT OK
Kenny2Scratch - NOT OK because of the capital S
Kenny2 - NOT OK
k2s - NOT OK, at least capitalize it';
my $regex = qr/\b(?:[Kk]en(?:ny2scratch)?|K2S)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}