import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:[Kk]en(?:ny2scratch)?|K2S)\\b";
final String string = "Kenny2scratch - OK\n"
+ "kenny2scratch - OK\n"
+ "Ken - OK\n"
+ "ken - OK though not preferred\n"
+ "K2S - OK for shorthand\n"
+ "Kenny - DEFINITELY NOT OK\n"
+ "Kenny2Scratch - NOT OK because of the capital S\n"
+ "Kenny2 - NOT OK\n"
+ "k2s - NOT OK, at least capitalize it";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}