// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:[Kk]en(?:ny2scratch)?|K2S)\b").unwrap();
let string = "Kenny2scratch - OK
kenny2scratch - OK
Ken - OK
ken - OK though not preferred
K2S - OK for shorthand
Kenny - DEFINITELY NOT OK
Kenny2Scratch - NOT OK because of the capital S
Kenny2 - NOT OK
k2s - NOT OK, at least capitalize it";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}