package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:[Kk]en(?:ny2scratch)?|K2S)\b`)
var str = `Kenny2scratch - OK
kenny2scratch - OK
Ken - OK
ken - OK though not preferred
K2S - OK for shorthand
Kenny - DEFINITELY NOT OK
Kenny2Scratch - NOT OK because of the capital S
Kenny2 - NOT OK
k2s - NOT OK, at least capitalize it`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}