const regex = new RegExp('\\b(?:[Kk]en(?:ny2scratch)?|K2S)\\b', 'g')
const str = `Kenny2scratch - OK
kenny2scratch - OK
Ken - OK
ken - OK though not preferred
K2S - OK for shorthand
Kenny - DEFINITELY NOT OK
Kenny2Scratch - NOT OK because of the capital S
Kenny2 - NOT OK
k2s - NOT OK, at least capitalize it`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}