#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\S)[^'\s]*('?)\S*\b"
Local $sString = "I'm a little teapot, short and stout. " & @CRLF & _
"Here is my handle, here is my spout. " & @CRLF & _
"When I get all steamed up - hear me shout! " & @CRLF & _
"Tip me over and pour me out. "
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)