package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\S)[^'\s]*('?)\S*\b`)
var str = `I'm a little teapot, short and stout.
Here is my handle, here is my spout.
When I get all steamed up - hear me shout!
Tip me over and pour me out. `
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}