const regex = /\b(\S)[^'\s]*('?)\S*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\S)[^\'\\s]*(\'?)\\S*\\b', 'gm')
const str = `I'm a little teapot, short and stout.
Here is my handle, here is my spout.
When I get all steamed up - hear me shout!
Tip me over and pour me out. `;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);