re = /\b(\S)[^'\s]*('?)\S*\b/m
str = 'I\'m a little teapot, short and stout.
Here is my handle, here is my spout.
When I get all steamed up - hear me shout!
Tip me over and pour me out. '
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result