# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(\S)[^'\s]*('?)\S*\b"
test_str = ("I'm a little teapot, short and stout. \n"
"Here is my handle, here is my spout. \n"
"When I get all steamed up - hear me shout! \n"
"Tip me over and pour me out. ")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.