$re = '/\b(\S)[^\'\s]*(\'?)\S*\b/m';
$str = 'I\'m a little teapot, short and stout.
Here is my handle, here is my spout.
When I get all steamed up - hear me shout!
Tip me over and pour me out. ';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;