import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\S)[^'\\s]*('?)\\S*\\b";
final String string = "I'm a little teapot, short and stout. \n"
+ "Here is my handle, here is my spout. \n"
+ "When I get all steamed up - hear me shout! \n"
+ "Tip me over and pour me out. ";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}