use strict;
my $str = 'I\'m a little teapot, short and stout.
Here is my handle, here is my spout.
When I get all steamed up - hear me shout!
Tip me over and pour me out. ';
my $regex = qr/\b(\S)[^'\s]*('?)\S*\b/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";