# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*\()|(_)([a-z])([a-z]*)|(Criteria.*)/$1\U$3\L$4\E$5/gm;t' <<< "function find_all_by_name_and_status(_i_find_all_by_name_and_statusCriteria find_all_by_name_and_status_criteria) ...
"