re = /(.*\()|(_)([a-z])([a-z]*)|(Criteria.*)/m
str = 'function find_all_by_name_and_status(_i_find_all_by_name_and_statusCriteria find_all_by_name_and_status_criteria) ...
'
subst = '$1\\U$3\\L$4\\E$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result