use strict;
my $str = 'function find_all_by_name_and_status(_i_find_all_by_name_and_statusCriteria find_all_by_name_and_status_criteria) ...
';
my $regex = qr/(.*\()|(_)([a-z])([a-z]*)|(Criteria.*)/mp;
my $subst = '$1\\U$3\\L$4\\E$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";