import re
regex = re.compile(r"(.*\()|(_)([a-z])([a-z]*)|(Criteria.*)", flags=re.MULTILINE)
test_str = ("function find_all_by_name_and_status(_i_find_all_by_name_and_statusCriteria find_all_by_name_and_status_criteria) ...\n\n")
subst = "$1\\U$3\\L$4\\E$5"
result = regex.sub(subst, test_str)
if result:
print(result)