const regex = /(.*\()|(_)([a-z])([a-z]*)|(Criteria.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\()|(_)([a-z])([a-z]*)|(Criteria.*)', 'gm')
const str = `function find_all_by_name_and_status(_i_find_all_by_name_and_statusCriteria find_all_by_name_and_status_criteria) ...
`;
const subst = `$1\U$3\L$4\E$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);