import Foundation
let pattern = #"(.*\()|(_)([a-z])([a-z]*)|(Criteria.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
function find_all_by_name_and_status(_i_find_all_by_name_and_statusCriteria find_all_by_name_and_status_criteria) ...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\U$3\L$4\E$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)