#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*\()|(_)([a-z])([a-z]*)|(Criteria.*)"
Local $sString = "function find_all_by_name_and_status(_i_find_all_by_name_and_statusCriteria find_all_by_name_and_status_criteria) ..." & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1\U$3\L$4\E$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)