# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/classification\\/showIndividualStageClassification\\/|\\/classification\\/showIndividualLeagueClassification\\/)(.*)/$1/g;t' <<< "/classification/showIndividualStageClassification/9371
/classification/showIndividualLeagueClassification/3026"